Back to overview
Resolved

Klarna is currently experiencing elevated errors

Sep 25, 2026 at 7:07am UTC
Affected services
Third-party service
Payments

Resolved
Sep 25, 2026 at 7:45am UTC

Payments are now being processed correctly.

Created
Sep 25, 2026 at 7:07am UTC

Klarna is currently experiencing elevated errors.
We will follow their updated and keep you informed.

This update will only affect Klarna via Stripe Connect.