Back to overview
Degraded
MitID Unavailable
Mar 31, 2026 at 08:43am UTC
Affected services
Third-party service
Payments
Resolved
Mar 31, 2026 at 12:07pm UTC
MitID reports the issue has been fixed.
Affected services
Created
Mar 31, 2026 at 08:43am UTC
MitID is currently experiencing technical issues affecting approvals. The issue is being handled by MitID, and we are monitoring the situation closely.
Affected services