Back to overview
Degraded

Connection issue to Nets platform.

May 21, 2026 at 8:03am UTC
Affected services
Third-party service
Payments

Resolved
May 21, 2026 at 1:13pm UTC

We are seeing that transactions through Nets’ platform are starting to be successful again, but we will continue monitoring the situation closely.

Please note that all failed capture and refund attempts must be retried manually.

Updated
May 21, 2026 at 11:52am UTC

We are still awaiting further updates from Nets regarding the ongoing issues.

A new update will be provided as soon as more information becomes available.

Created
May 21, 2026 at 8:03am UTC

Payments via Nets acquirer are currently experiencing issues due to instability on Nets’ authorization platform.

We are currently awaiting further updates from Nets.

This affects acquirer Nets, NetsTeller, Bambora, Swedbank and Elavon.

As a temporary workaround, these can be disabled temporarily on your pensopay portal.