Back to overview
Resolved

3D-Secure authentication on MasterCard

Jul 15, 2026 at 8:14am UTC
Affected services
Third-party service
Payments

Resolved
Jul 15, 2026 at 9:07am UTC

We are seeing MasterCard transactions are now being approved with 3d-secure.

MasterCard still has not confirmed a fix, but we are seeing an improvement in succesful authorizations.

Created
Jul 15, 2026 at 8:14am UTC

Mastercard has confirmed a network-side incident affecting authentications.

Their teams are actively investigating and will provide an update as soon as possible.

Visa authentications remain unaffected.

We will update this page as we hear more.

Mobilepay payments are unaffected regardless of card scheme.